Endlich IPv6 zu Hause


7. August 2012 11:22h:
Der lang ersehnte Anruf eines Silver Server Mitarbeiters, wann man denn umstellen kann.
„Na sofort“ – meine Antwort.

Also:
1. in IPV6 ist alles anders
2. Wenn´s alles richtig funktioniert, ist es sehr stabil und einfach

Erste Versuche mit Teredo:
ipv6 install
netsh int ipv6 set teredo client teredo.remlab.net 60 34567
Geht einfach und auch über NAT – über UDP 3544
Nachteil: man weiss nie wirklich, über welches Gateway man ins Internet geht. – Sehr wahrscheinlich NICHT über das des eigenen Providers.

Heute Teredo wieder abgedreht:
netsh int ipv6 set teredo disabled

Als Router verwende ich momentan noch eine auf VMware Player (3.1.3 build-324285) virtualisierte Mikrotik 5.19 auf 2 Netzwerkadaptern.

Von Silver Server habe ich die Konfiguration für den 6to4 Tunnel bekommen und kann jetzt stolz über 4.722.366.482.869.645.213.696 (also ~4,7 Trilliarden =10^21) IPv6 Adressen verfügen. (das ist ein /56er Subnet)

Mikrotik IPv6 6to4 config:

/interface 6to4
add disabled=no local-address=[myLocalIpV4 Tunnel Endpoint] mtu=1420 name=sit1 remote-address=[SilverServer Tunnel Endpoint]

/ipv6 address
add address=2001:aba:1:aff2:affe::/64 advertise=yes disabled=no eui-64=no \
interface=1_LAN
add address=2001:aba:1:aff0:3c74:7aff:fe2b:1964/64 advertise=yes disabled=no \
eui-64=yes interface=sit1

/ipv6 route
add disabled=no distance=1 dst-address=2000::/3 gateway=sit1 scope=30 target-scope=10

Die Addressen hier sind modifiziert. – Bitte die vom Provider übermittelten benutzen!
Ach ja, der 6to4 Tunnel benutzt IP Protokoll 41 (sollte am WAN interface der input queue erlaubt sein)

Und wenn dann zum Schluss bei der Eingabe von ping ipv6.google.com

Ping ipv6.l.google.com [2a00:1450:4016:801::1014] mit 32 Bytes Daten:

Antwort von 2a00:1450:4016:801::1014: Zeit=80ms
Antwort von 2a00:1450:4016:801::1014: Zeit=79ms
Antwort von 2a00:1450:4016:801::1014: Zeit=79ms
Antwort von 2a00:1450:4016:801::1014: Zeit=79ms

Ping-Statistik für 2a00:1450:4016:801::1014:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 79ms, Maximum = 80ms, Mittelwert = 79ms

… steht, weiss man dass alles funktioniert.
*ggg*

Advertisements

Über kletool

yes, that´s me :-) mein Blog auf wordpress.com Ich lehne sämtliche Haftung für Schäden ab, die Resultat der Inhalte dieses Blogs sind. Auf verlinkte Seiten habe ich keinen Einfluß. - Auch hier keine Haftung!
Dieser Beitrag wurde unter IPv6, Mikrotik veröffentlicht. Setze ein Lesezeichen auf den Permalink.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s